ارائه‌دهنده‌ی راهکارهای نرم‌ افزارهای سازمانی
ارائه‌دهنده‌ی راهکارهای نرم‌ افزارهای سازمانی

آخرین به‌روزرسانی JavaScript را نصب نکنید

همکاران سیستم- کارشناسان از کشف حفره امنیتی بسیار جدی در یکی از محبوب‌ترین بسته‌های مدیریتی JavaScript خبر دادند و اعلام کردند این آسیب‌پذیری می‌تواند روی فولدرهای حیاتی سیستم‌های مبتنی بر لینوکس از جمله etc/ ، usr/ و boot تاثیر بگذارد و بدون مجوز کاربر آن‌ها را تغییر دهد.
به گزارش وب سایت theinquirer، این حفره نرم‌افزاری در بسته مدیریتی Node Package Manager یا NPM شناسایی شده است و باعث می‌شود یک سیستم به صورت کامل مختل شود یا چندین اپلیکیشن نصب شده روی آن از کار بیفتند. همچنین این احتمال وجود دارد که حفره نرم‌افزاری مذکور امکان بوت شدن سیستم هنگام ایجاد هر گونه تغییر فایل توسط کاربر را غیرممکن کند.
بر اساس گزارش‌های منتشر شده از سوی کاربرانی که به‌روزرسانی NPM را نصب کردند، این آسیب‌پذیری اختلالات فراوانی را برای آنها ایجاد کرده است. لازم به ذکر است این به‌روزرسانی با نام NPM v۵.۷.۰ ایجاد شده است.

بخش اعظم کاربرانی که در نتیجه نصب این به‌روزرسانی دچار مشکل شدند را توسعه‌دهندگان و مهندسان نرم‌افزار تشکیل می دهند و آنها اعلام کردند که تنها راه برای برطرف کردن مشکل مذکور نصب دوباره سیستم‌ها به صورت کامل است یا اینکه سیستم عامل به نسخه قبل از نصب فایل به‌روزرسانی بگردد.
یکی از کاربران در این زمینه گفت: «در اختیار گرفتن این به‌روزرسانی باعث شد که با نصب یک فایل، سه محصول اصلی روی سرور به طور کامل مختل شود.»

دیدگاه خود را ثبت کنید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *